Back to overview
Maintenance

Update ChaosSquad Network to newest game version

Jul 25 at 11:00pm CEST  –  Jul 26 at 12:20am CEST
Affected services
Proxy
Lobby
Creative
CastleConquest 2
CombatTest
ACM-2 Buildserver
Bedwars

Resolved
Jul 25 at 11:00pm CEST

The ChaosSquad Network is currently updated to the newest game version. This can take some time.